aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2017-09-13 11:51:14 -0700
committerJohn Crispin <john@phrozen.org>2017-09-20 09:00:25 +0200
commitfeb1907270622f094a54ef23a20e8991908eca25 (patch)
tree890cdece315b7abf55edece5218f1f55ad8c77d7 /include/image-commands.mk
parentf8a5ac1a8835b9c826286469379a143ff9e532d5 (diff)
downloadupstream-feb1907270622f094a54ef23a20e8991908eca25.tar.gz
upstream-feb1907270622f094a54ef23a20e8991908eca25.tar.bz2
upstream-feb1907270622f094a54ef23a20e8991908eca25.zip
build: add image command for installing zImage file.
Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 2aac8fb15d..acf25d64da 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -114,6 +114,11 @@ define Build/install-dtb
)
endef
+define Build/install-zImage
+ $(CP) $(KDIR)/zImage \
+ $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE_SANITIZED)-zImage
+endef
+
define Build/fit
$(TOPDIR)/scripts/mkits.sh \
-D $(DEVICE_NAME) -o $@.its -k $@ \