aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-10-09 13:50:03 +0200
committerAlexander Couzens <lynxis@fe80.eu>2017-10-09 16:10:05 +0200
commit49b84624eb694ed8238472db758708384fe62ce6 (patch)
tree63ff80125816fed8a6052639233a0b2d4805fb68 /include/image-commands.mk
parenta5d016f3615c10a326a507dcb24afe8adcd48396 (diff)
downloadupstream-49b84624eb694ed8238472db758708384fe62ce6.tar.gz
upstream-49b84624eb694ed8238472db758708384fe62ce6.tar.bz2
upstream-49b84624eb694ed8238472db758708384fe62ce6.zip
image-commands: tplink-v2-header: pass kernel loadaddr and entry
Initramfs images won't boot if the default loadaddr and entrypont is different. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 4fe8c0f456..aaece705d2 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -249,7 +249,8 @@ endef
define Build/tplink-v2-header
$(STAGING_DIR_HOST)/bin/mktplinkfw2 \
- -c -H $(TPLINK_HWID) -W $(TPLINK_HWREV) \
+ -c -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -L $(KERNEL_LOADADDR) \
+ -E $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-w $(TPLINK_HWREVADD) -F "$(TPLINK_FLASHLAYOUT)" \
-T $(TPLINK_HVERSION) -V "ver. 2.0" \
-k $@ -o $@.new $(1)