aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2018-05-15 19:02:48 +0200
committerJohn Crispin <john@phrozen.org>2018-05-22 20:34:14 +0200
commit399495a952bf687d9c59226bddf4e73d3b42b30c (patch)
treef647f412dd329a090c0e8141b47371eb6483e2d5 /include/image-commands.mk
parentce91c85e01050cb19c89c9a19369a56a94619e7f (diff)
downloadupstream-399495a952bf687d9c59226bddf4e73d3b42b30c.tar.gz
upstream-399495a952bf687d9c59226bddf4e73d3b42b30c.tar.bz2
upstream-399495a952bf687d9c59226bddf4e73d3b42b30c.zip
build: add apend-uboot command
This commit adds an append-uboot command to append U-Boot from the bin-directory. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index e0322080e9..395e31f994 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -186,6 +186,10 @@ define Build/append-ubi
rm $@.tmp
endef
+define Build/append-uboot
+ dd if=$(UBOOT_PATH) >> $@
+endef
+
define Build/pad-to
dd if=$@ of=$@.new bs=$(1) conv=sync
mv $@.new $@