aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-02-19 23:03:00 +0100
committerStijn Tintel <stijn@linux-ipv6.be>2018-02-19 23:54:38 +0100
commit138c76332b7e39b3c4e3018e7792e74645ab0c7a (patch)
tree40ff43ada77e25d92c17783890014f4207d6cc3f /include/image-commands.mk
parent858ff4f3e1877a4baf882788cfd99deab26fbb5e (diff)
downloadupstream-138c76332b7e39b3c4e3018e7792e74645ab0c7a.tar.gz
upstream-138c76332b7e39b3c4e3018e7792e74645ab0c7a.tar.bz2
upstream-138c76332b7e39b3c4e3018e7792e74645ab0c7a.zip
build: add --force option to gzip in Build/gzip
When using pigz, a parallel gzip implementation, the gzip step in the image build for some targets fails, because the image filename already has the .gz extension. This results in an emtpy image file. Fix this by adding the --force option to gzip in the Build/gzip macro. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Tested-by: Martin Schleier <drahemmaps@gmx.net>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 555a9e5906..9ec3a84884 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -133,7 +133,7 @@ define Build/lzma-no-dict
endef
define Build/gzip
- gzip -9n -c $@ $(1) > $@.new
+ gzip --force -9n -c $@ $(1) > $@.new
@mv $@.new $@
endef