aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-07-06 18:10:22 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-07-22 23:29:50 +0200
commitf08f754993d5e9a1952400528ce5405910d1d1a4 (patch)
tree6ce114b612ae26cec733418f715b40038dc04afb /include/image-commands.mk
parentb3cb0e75884222e141a40443c25d20deedf7a552 (diff)
downloadupstream-f08f754993d5e9a1952400528ce5405910d1d1a4.tar.gz
upstream-f08f754993d5e9a1952400528ce5405910d1d1a4.tar.bz2
upstream-f08f754993d5e9a1952400528ce5405910d1d1a4.zip
build: move mktplinkfw-combined command to image-commands.mk
We will need "mktplinkfw-combined" command also in the "ramips" target for new MediaTek based TP-Link devices, with "safeloader" image type. Also, rename the command to "tplink-v1-header", use "VERSION_DIST" variable instead of "OpenWrt" and allow passing additional parameters. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index ce84e3f11c..2aac8fb15d 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -233,6 +233,15 @@ define Build/sysupgrade-tar
$@
endef
+define Build/tplink-v1-header
+ $(STAGING_DIR_HOST)/bin/mktplinkfw \
+ -c -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -L $(KERNEL_LOADADDR) \
+ -E $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -m $(TPLINK_HEADER_VERSION) -N "$(VERSION_DIST)" -V $(REVISION) \
+ -k $@ -o $@.new $(1)
+ @mv $@.new $@
+endef
+
define Build/tplink-v2-header
$(STAGING_DIR_HOST)/bin/mktplinkfw2 \
-c -V "ver. 2.0" -B $(TPLINK_BOARD_ID) $(1) -k $@ -o $@.new