aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2018-12-01 19:41:34 +0100
committerChristian Lamparter <chunkeey@gmail.com>2018-12-17 00:21:34 +0100
commit6c3c4436ee1af0742de7c29bd9c4f10990ed2019 (patch)
tree9c1c366c654a69c16e30d149b3a3323f6b7474ae /include/image-commands.mk
parent247fdceab6caa1d3bc29ca629833a2f705eb9d59 (diff)
downloadupstream-6c3c4436ee1af0742de7c29bd9c4f10990ed2019.tar.gz
upstream-6c3c4436ee1af0742de7c29bd9c4f10990ed2019.tar.bz2
upstream-6c3c4436ee1af0742de7c29bd9c4f10990ed2019.zip
ath79: add d-link dir-825-c1 and dir-835-a1
This commit ports both dir-825-c1 and dir-835-a1 from ar71xx to ath79. They're pretty much identical, except dir-835-a1 has less LEDs. The routers come with 128 MByte of RAM and 16 MBytes of flash and sport 2.4GHz and 5.0GHz wireless. Both routers have entries already in OpenWrt's TOH. Please check there for more information on these antiquities. https://openwrt.org/toh/hwdata/d-link/d-link_dir-825_c1 https://openwrt.org/toh/hwdata/d-link/d-link_dir-835_a1 Installation: 1. Connect to the web interface of the vendor firmware (usually listening on 192.168.0.1). 2. Go to "Tools", then "Firmware". 3. In the "Firmware Upgrade" box click "Browse". 4. Select the OpenWrt factory image for your router. 5. Click "Upload", confirm the popups if you agree to flash the file you selected. 6. Wait for firmware upgrade to complete. It takes about 5 minutes. Run-tested on dir-825-c1. dir-835-a1 should work as well, but I don't have this router so I can't confirm. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net> Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [trivial changes]
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 63539bad08..4e93115963 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -56,6 +56,18 @@ define Build/cameo-factory
mv $@.new $@
endef
+# blow up binary to given size and put a given string at its end:
+# cameo-factory <size[k]> <string>
+define Build/cameo-factory
+ factory_stamp=$(word 2,$(1)); \
+ ((reduced_size=$(subst k,*1024,$(word 1,$(1)))-$${#factory_stamp})); \
+ ( \
+ dd if=$@ bs=$$reduced_size conv=sync; \
+ echo -n $$factory_stamp; \
+ ) > $@.new && \
+ mv $@.new $@
+endef
+
define Build/eva-image
$(STAGING_DIR_HOST)/bin/lzma2eva $(KERNEL_LOADADDR) $(KERNEL_LOADADDR) $@ $@.new
mv $@.new $@