aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-12-04 20:24:24 +0100
committerFelix Fietkau <nbd@nbd.name>2017-12-04 20:24:51 +0100
commite23ff063d3d1ee6820daf170a2c4c0e1810e4591 (patch)
tree9aa875a69e0344a182f1ad0ed248a6b88999fdcb /include/image-commands.mk
parentaec1b6bfcbe1345eb10d8d104cb0d7dfc1f44423 (diff)
downloadupstream-e23ff063d3d1ee6820daf170a2c4c0e1810e4591.tar.gz
upstream-e23ff063d3d1ee6820daf170a2c4c0e1810e4591.tar.bz2
upstream-e23ff063d3d1ee6820daf170a2c4c0e1810e4591.zip
build: avoid failing in append-metadata if image could not be generated
The image build might have failed due to a size check Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 1ec5252972..8db046bdea 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -281,7 +281,7 @@ metadata_json = \
}'
define Build/append-metadata
- $(if $(SUPPORTED_DEVICES),echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
+ $(if $(SUPPORTED_DEVICES),-echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
endef
define Build/kernel2minor