aboutsummaryrefslogtreecommitdiffstats
path: root/include/image-commands.mk
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2018-03-28 13:34:52 +1100
committerHauke Mehrtens <hauke@hauke-m.de>2018-05-21 18:07:48 +0200
commitfba168f5745acac95db519a9984b62e3e508df6a (patch)
treeba26c42bd7f8e8b7d8d673acee780ee01658e14b /include/image-commands.mk
parent39e87e0ffc4eabf27d25459a369be425e9ef0474 (diff)
downloadupstream-fba168f5745acac95db519a9984b62e3e508df6a.tar.gz
upstream-fba168f5745acac95db519a9984b62e3e508df6a.tar.bz2
upstream-fba168f5745acac95db519a9984b62e3e508df6a.zip
build: use busybox gzip compatible force option
commit 138c763 ("build: add --force option to gzip in Build/gzip") added the --force flag to the gzip invocation. Under environments with busybox gzip (e.g Alpine Linux), this fails as busybox only recognizes "-f". Signed-off-by: Mathew McBride <matt@traverse.com.au>
Diffstat (limited to 'include/image-commands.mk')
-rw-r--r--include/image-commands.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index a848655399..e0322080e9 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -135,7 +135,7 @@ define Build/lzma-no-dict
endef
define Build/gzip
- gzip --force -9n -c $@ $(1) > $@.new
+ gzip -f -9n -c $@ $(1) > $@.new
@mv $@.new $@
endef