aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-11-04 15:54:27 +0100
committerFelix Fietkau <nbd@nbd.name>2021-11-04 16:43:32 +0100
commit9faa22fcee8f9bc5310239661838ab68c7e7c104 (patch)
treef30cf051bd511d430b1d37c084cfca7b7e019699 /include/host-build.mk
parent94b0849c19848beda9e1a215bcae0daac6927ff0 (diff)
downloadupstream-9faa22fcee8f9bc5310239661838ab68c7e7c104.tar.gz
upstream-9faa22fcee8f9bc5310239661838ab68c7e7c104.tar.bz2
upstream-9faa22fcee8f9bc5310239661838ab68c7e7c104.zip
build: fix host package unpack if git-src is used
If the package download step is skipped, it needs to be performed for the host build instead. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index cfa29419aa..b68c8c4536 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -205,5 +205,5 @@ endif
define HostBuild
$(HostBuild/Core)
- $(if $(if $(PKG_HOST_ONLY),,$(STAMP_PREPARED)),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
+ $(if $(if $(PKG_HOST_ONLY),,$(if $(and $(filter host-%,$(MAKECMDGOALS)),$(PKG_SKIP_DOWNLOAD)),,$(STAMP_PREPARED))),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
endef