aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2022-09-07 23:50:36 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2022-12-04 17:17:18 +0100
commitac7b1c8e9464ff2fafd682ede144564d99930063 (patch)
treea0f25967359863f029b83f90ff1555fb77807f33 /include/host-build.mk
parent439e19de967bffcc7a9fa4d2e16e873a67b95738 (diff)
downloadupstream-ac7b1c8e9464ff2fafd682ede144564d99930063.tar.gz
upstream-ac7b1c8e9464ff2fafd682ede144564d99930063.tar.bz2
upstream-ac7b1c8e9464ff2fafd682ede144564d99930063.zip
build: handle directory with whitespace in AUTOREMOVE clean
Package with whitespace in their build directory are not correctly removed when CONFIG_AUTOREMOVE is enabled. This is caused by xargs that use whitespace as delimiters. To handle this use \0 as the delimiter and set find to use \0 as the delimiter. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com> (cherry picked from commit dccee21792b89031bcd801030de403f195d80278)
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index c6f594be35..22fcc31f15 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -198,8 +198,8 @@ ifndef DUMP
ifneq ($(CONFIG_AUTOREMOVE),)
host-compile:
- $(FIND) $(HOST_BUILD_DIR) -mindepth 1 -maxdepth 1 -not '(' -type f -and -name '.*' -and -size 0 ')' | \
- $(XARGS) rm -rf
+ $(FIND) $(HOST_BUILD_DIR) -mindepth 1 -maxdepth 1 -not '(' -type f -and -name '.*' -and -size 0 ')' -print0 | \
+ $(XARGS) -0 rm -rf
endif
endef
endif