aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-07-24 15:23:05 +0200
committerJo-Philipp Wich <jo@mein.io>2018-12-18 09:50:20 +0100
commitc0673db23f1c98ccb9e5f71ec21b94153684fc80 (patch)
treeb8c14d072e340ab43f4f3c2f51bf137f5c28bb4b /include/host-build.mk
parentf8750b1a433fc6f590dc5214a90b6b370f8833da (diff)
downloadupstream-c0673db23f1c98ccb9e5f71ec21b94153684fc80.tar.gz
upstream-c0673db23f1c98ccb9e5f71ec21b94153684fc80.tar.bz2
upstream-c0673db23f1c98ccb9e5f71ec21b94153684fc80.zip
build: do not override CCACHE_DIR when ccache is disabled
Signed-off-by: Jo-Philipp Wich <jo@mein.io> (backported from 991c7a4f69976f72bcee3f76d6917b224da45ea1)
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index a2a31ae048..827ea6bbfb 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -132,7 +132,7 @@ define Host/Exports/Default
$(1) : export STAGING_PREFIX=$$(HOST_BUILD_PREFIX)
$(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig:$$(HOST_BUILD_PREFIX)/lib/pkgconfig
$(1) : export PKG_CONFIG_LIBDIR=$$(HOST_BUILD_PREFIX)/lib/pkgconfig
- $(1) : export CCACHE_DIR:=$(STAGING_DIR_HOST)/ccache
+ $(if $(CONFIG_CCACHE),$(1) : export CCACHE_DIR:=$(STAGING_DIR_HOST)/ccache)
$(if $(HOST_CONFIG_SITE),$(1) : export CONFIG_SITE:=$(HOST_CONFIG_SITE))
$(if $(IS_PACKAGE_BUILD),$(1) : export PATH=$$(TARGET_PATH_PKG))
endef