aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-30 21:12:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-30 21:12:39 +0000
commita96b79a6d47000c1949025aa442322339c871d20 (patch)
tree36c08c3a3571e181641a7399e73eea11e4b1352d /include/host-build.mk
parentbeaa7e3c3710546225d0a4e76a6016975f358fcb (diff)
downloadupstream-a96b79a6d47000c1949025aa442322339c871d20.tar.gz
upstream-a96b79a6d47000c1949025aa442322339c871d20.tar.bz2
upstream-a96b79a6d47000c1949025aa442322339c871d20.zip
clean up recursive dependency handling, use timestamp.pl again, because it saves memory and execution time
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8558 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 47ec9b0d3a..581c2cfd4e 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/unpack.mk
include $(INCLUDE_DIR)/depends.mk
-STAMP_PREPARED:=$(PKG_BUILD_DIR)/.prepared_$(shell find ${CURDIR} $(PKG_FILE_DEPEND) $(DEP_FINDPARAMS) | md5s)
+STAMP_PREPARED:=$(PKG_BUILD_DIR)/.prepared_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),))
STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured
STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.$(PKG_NAME)_installed
@@ -82,9 +82,8 @@ endif
ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)
define HostBuild/Autoclean
- $(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
$(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED))
- $(if $(if $(Build/Compile),$(filter prepare,$(MAKECMDGOALS)),1),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*"))
+ $(if $(if $(Build/Compile),$(filter prepare,$(MAKECMDGOALS)),1),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT)))
endef
endif