aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-18 14:00:48 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-18 23:57:07 +0100
commit6cf067d084cc551c721e98b6d6c6403a63e521d5 (patch)
treecba95f698e521269aa3530791b758ac8f636d842 /include/host-build.mk
parentc99f8815680fb4abf42cbb2e9d1a909f8f373b02 (diff)
downloadupstream-6cf067d084cc551c721e98b6d6c6403a63e521d5.tar.gz
upstream-6cf067d084cc551c721e98b6d6c6403a63e521d5.tar.bz2
upstream-6cf067d084cc551c721e98b6d6c6403a63e521d5.zip
build: define common subdir targets in rules.mk
Reduce build system clutter and enable further rework Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk17
1 files changed, 4 insertions, 13 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 6c2f91581b..0bd386781d 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -168,13 +168,11 @@ ifndef DUMP
touch $(HOST_STAMP_BUILT)
touch $$@
+ $(call DefaultTargets,$(patsubst %,host-%,$(DEFAULT_SUBDIR_TARGETS)))
ifndef STAMP_BUILT
- prepare: host-prepare
- compile: host-compile
- install: host-install
- clean: host-clean
- update: host-update
- refresh: host-refresh
+ $(foreach t,$(DEFAULT_SUBDIR_TARGETS),
+ $(t): host-$(t)
+ )
endif
host-prepare: $(HOST_STAMP_PREPARED)
@@ -187,13 +185,6 @@ ifndef DUMP
rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_INSTALLED) $(HOST_STAMP_BUILT)
endef
-
- download:
- prepare:
- compile:
- install:
- clean:
-
endif
define HostBuild