aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-05 14:10:31 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-05 14:21:27 +0100
commit28f9df62f513c073b790b2d4c78a72649adce6ef (patch)
tree23e6acfa7e4f6af48ae8a5575007fcc8a7a04ab7 /include/host-build.mk
parent8160beb014baf55cd917cec50c416b69519c6a4d (diff)
downloadupstream-28f9df62f513c073b790b2d4c78a72649adce6ef.tar.gz
upstream-28f9df62f513c073b790b2d4c78a72649adce6ef.tar.bz2
upstream-28f9df62f513c073b790b2d4c78a72649adce6ef.zip
build: fix HOST_CONFIGURE_VARS placement
Ensure that HOST_CONFIGURE_VARS are set before the actual configure command instead of passing them as configure command arguments. This change brings host-build.mk in line with package-defaults.mk and makes host configure environment variables work as expected. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index b2f017bee2..f2109851d9 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -80,9 +80,9 @@ define Host/Configure/Default
$(if $(HOST_CONFIGURE_PARALLEL),+)(cd $(HOST_BUILD_DIR)/$(3); \
if [ -x configure ]; then \
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
+ $(HOST_CONFIGURE_VARS) \
$(2) \
$(HOST_CONFIGURE_CMD) \
- $(HOST_CONFIGURE_VARS) \
$(HOST_CONFIGURE_ARGS) \
$(1); \
fi \