aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 21:48:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 21:48:39 +0000
commitce02916d5f22d249fc89c5f00b2d849f205b0b74 (patch)
treeb605e4da5f6167887f70d228c159af4b15b734ca /include/host-build.mk
parent8ba1f30a1787dff26565bfbf8f66dd3318c42db0 (diff)
downloadupstream-ce02916d5f22d249fc89c5f00b2d849f205b0b74.tar.gz
upstream-ce02916d5f22d249fc89c5f00b2d849f205b0b74.tar.bz2
upstream-ce02916d5f22d249fc89c5f00b2d849f205b0b74.zip
same for host builds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8246 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index d83446558e..e934c91c66 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -84,7 +84,7 @@ ifneq ($(CONFIG_AUTOREBUILD),)
define HostBuild/Autoclean
$(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
$(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED))
- $(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*")
+ $(if $(filter prepare,$(MAKECMDGOALS)),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),$(PKG_BUILD_DIR)/.dep_files, -and -not -path "/.*" -and -not -path "*/ipkg*"))
endef
endif