aboutsummaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2018-05-28 11:26:50 +0200
committerPetr Štetiar <ynezz@true.cz>2019-03-22 00:40:29 +0100
commit9be901061e14b4f9a4ddd17e2e858bfc59e18c18 (patch)
tree9a3238653d460d83edad5a0eadcbcffa6d31179b /include/feeds.mk
parent94ffb7be4d0a7fe6a48ccd9d4aaf14cef0b15eea (diff)
downloadupstream-9be901061e14b4f9a4ddd17e2e858bfc59e18c18.tar.gz
upstream-9be901061e14b4f9a4ddd17e2e858bfc59e18c18.tar.bz2
upstream-9be901061e14b4f9a4ddd17e2e858bfc59e18c18.zip
build: suppress error output in feeds.mk
If no feed.conf or feeds.conf.default is found on image generation with the imagebuilder we always get the following message "Unable to open feeds configuration at <dir>/scripts/feeds line 48." on std error. To get rid off this needless warning on image generation with the imagebuilder supress the output in feeds.mk. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index 4d85a47599..9637424c5b 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -9,7 +9,7 @@
-include $(TMP_DIR)/.packageauxvars
FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
-FEEDS_AVAILABLE:=$(sort $(FEEDS_INSTALLED) $(shell $(SCRIPT_DIR)/feeds list -n))
+FEEDS_AVAILABLE:=$(sort $(FEEDS_INSTALLED) $(shell $(SCRIPT_DIR)/feeds list -n 2>/dev/null))
PACKAGE_SUBDIRS=$(PACKAGE_DIR)
ifneq ($(CONFIG_PER_FEED_REPO),)