aboutsummaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-11-08 05:47:39 +0100
committerFelix Fietkau <nbd@nbd.name>2016-11-08 10:49:51 +0100
commit64c386c5662e923d284b1c5b742cb72d7ad24671 (patch)
tree9bf3a4048503b37729b0c390e618069d2d22357f /include/feeds.mk
parent7ee661def6da779917ef405e04eb7eb4230ebb0a (diff)
downloadupstream-64c386c5662e923d284b1c5b742cb72d7ad24671.tar.gz
upstream-64c386c5662e923d284b1c5b742cb72d7ad24671.tar.bz2
upstream-64c386c5662e923d284b1c5b742cb72d7ad24671.zip
build: remove stale .ipk files if package dir changes
If a package nonshared status is changed, a stale .ipk file might still be present in the old package directory. Remove the .ipk file from all package directories when building a new one (or explicitly running clean) Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index c79c941ffa..2ff57e5762 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -25,6 +25,10 @@ endif
PACKAGE_DIR_ALL := $(TOPDIR)/staging_dir/packages/$(BOARD)
+opkg_package_files = $(wildcard \
+ $(foreach dir,$(PACKAGE_SUBDIRS), \
+ $(foreach pkg,$(1), $(dir)/$(pkg)_*.ipk)))
+
PKG_CONFIG_DEPENDS += \
CONFIG_PER_FEED_REPO \
CONFIG_PER_FEED_REPO_ADD_DISABLED \