aboutsummaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-01-05 10:43:55 +0100
committerJo-Philipp Wich <jo@mein.io>2018-01-10 21:27:31 +0100
commit4700544e4068cb72932148ac1ecd294ca1388671 (patch)
tree5f5b902f7d3264d9c3ffbd53e1cf6e6bf9994bce /include/download.mk
parent012d20eebe3aec0818aa949eb7b14754640df797 (diff)
downloadupstream-4700544e4068cb72932148ac1ecd294ca1388671.tar.gz
upstream-4700544e4068cb72932148ac1ecd294ca1388671.tar.bz2
upstream-4700544e4068cb72932148ac1ecd294ca1388671.zip
downloads.mk: introduce name-agnostic PROJECT_GIT variable
Introduce a name-agnostic PROJECT_GIT variable poiting to https://git.openwrt.org/ and declare LEDE_GIT and OPENWRT_GIT as aliases to it. After some transition time we can drop this alias variables. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index 0a25641738..2ba8a7bdf4 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -6,8 +6,10 @@
# See /LICENSE for more information.
#
-OPENWRT_GIT = http://git.openwrt.org
-LEDE_GIT = https://git.lede-project.org
+PROJECT_GIT = https://git.openwrt.org
+
+OPENWRT_GIT = $(PROJECT_GIT)
+LEDE_GIT = $(PROJECT_GIT)
ifdef PKG_SOURCE_VERSION
PKG_VERSION ?= $(if $(PKG_SOURCE_DATE),$(PKG_SOURCE_DATE)-)$(call version_abbrev,$(PKG_SOURCE_VERSION))