aboutsummaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-17 02:37:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-17 02:37:10 +0000
commit2f5a8c4214e03ee0bb0447e693f7ef67d42a52de (patch)
treec00ac508c248f68fa4b8570d162e0e07f556378a /include/download.mk
parentfb5f8649194c5412324e25fa2c33b9197d0126fb (diff)
downloadupstream-2f5a8c4214e03ee0bb0447e693f7ef67d42a52de.tar.gz
upstream-2f5a8c4214e03ee0bb0447e693f7ef67d42a52de.tar.bz2
upstream-2f5a8c4214e03ee0bb0447e693f7ef67d42a52de.zip
fix download reverse depends
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14907 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index 811c42a3c3..78848b9c95 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -5,7 +5,7 @@
# See /LICENSE for more information.
#
-DOWNLOAD_RDEP:=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
+DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
# Try to guess the download method from the URL
define dl_method
@@ -132,7 +132,9 @@ define Download
endif
)
- $(if $(DOWNLOAD_RDEP),$(DOWNLOAD_RDEP): $(DL_DIR)/$(FILE))
+ $(foreach dep,$(DOWNLOAD_RDEP),
+ $(dep): $(DL_DIR)/$(FILE)
+ )
download: $(DL_DIR)/$(FILE)
$(DL_DIR)/$(FILE):