aboutsummaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2022-09-09 16:01:21 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2022-09-11 11:07:53 +0200
commitf34690e487e13ee772b2dca3e7fab2a2bd1e77a1 (patch)
treeabc6135084daf103ccfa5a4c0d20699ab9ddaf25 /include/depends.mk
parent0c45db5560df47a0344a21c2443a4f2889c42ac8 (diff)
downloadupstream-f34690e487e13ee772b2dca3e7fab2a2bd1e77a1.tar.gz
upstream-f34690e487e13ee772b2dca3e7fab2a2bd1e77a1.tar.bz2
upstream-f34690e487e13ee772b2dca3e7fab2a2bd1e77a1.zip
depends.mk: fix typo in rdep function
Just like later in the file, the precursor to <stampfile>_check <stampfile>_check.1 is supposed to be moved to <stampfile>_check before it is touched. This line would error if it was ever run. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/depends.mk b/include/depends.mk
index 465e4e952a..073fb03632 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -27,7 +27,7 @@ ifneq ($(wildcard $(2)),)
{ [ \! -f "$(3)" ] || diff $(3) $(3).1 >/dev/null; } && \
) \
{ \
- [ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
+ [ -f "$(2)_check.1" ] && mv "$(2)_check.1" "$(2)_check"; \
$(TOPDIR)/scripts/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
$(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
touch -r "$(2)" "$(2)_check"; \