aboutsummaryrefslogtreecommitdiffstats
path: root/include/cmake.mk
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2021-11-25 02:12:58 +0100
committerPaul Spooren <mail@aparcar.org>2022-01-17 09:14:26 +0100
commit88204bfa82f982a986d2aa3e166a4c5946040308 (patch)
tree7d10a3c76c12f1cdf00ec192cb40efe823a4f0d2 /include/cmake.mk
parent87d489f67a35968242cd4f192dc363dc87056844 (diff)
downloadupstream-88204bfa82f982a986d2aa3e166a4c5946040308.tar.gz
upstream-88204bfa82f982a986d2aa3e166a4c5946040308.tar.bz2
upstream-88204bfa82f982a986d2aa3e166a4c5946040308.zip
treewide: drop use of which
Ubuntu started to flag which as deprecated and it seems which is not really standard and may vary across Distro. Drop the use of which and use the standard 'command -v' for this simple task. Which is still present in the prereq if some package/script still use which. A utility script called command_all.sh is implemented that will just mimic the output of which -a. Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
Diffstat (limited to 'include/cmake.mk')
-rw-r--r--include/cmake.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index b9a7e36dee..9b169b0693 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -24,7 +24,7 @@ MAKE_PATH = $(firstword $(CMAKE_BINARY_SUBDIR) .)
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
cmake_tool=$(TOOLCHAIN_DIR)/bin/$(1)
else
- cmake_tool=$(shell which $(1))
+ cmake_tool=$(shell command -v $(1))
endif
ifeq ($(CONFIG_CCACHE),)