aboutsummaryrefslogtreecommitdiffstats
path: root/include/cmake.mk
diff options
context:
space:
mode:
authorClemens Fruhwirth <clemens@endorphin.org>2021-01-29 19:57:37 +0100
committerPetr Štetiar <ynezz@true.cz>2021-03-03 23:02:30 +0100
commit27c5db998cba4bc76b5c9dcf71120181cb813886 (patch)
tree31b0aa603e7207d51f1528309f507ef118932212 /include/cmake.mk
parenta29b3983248588505e927317a162edb8187b94f9 (diff)
downloadupstream-27c5db998cba4bc76b5c9dcf71120181cb813886.tar.gz
upstream-27c5db998cba4bc76b5c9dcf71120181cb813886.tar.bz2
upstream-27c5db998cba4bc76b5c9dcf71120181cb813886.zip
Revert "build: replace which with Bash command built-in"
This reverts commit c7aec47e5e3a3ff7b5fdaa11cd1e62cae6746acb. The original commit replaces 'which' with 'command'. Sadly most of them are not equivalent and for 'which -a', there is no easy replacements that would not reimplement PATH parsing logic. Hence revert. Keeping a dependency on which is absolutely fine. Signed-off-by: Clemens Fruhwirth <clemens@endorphin.org> (cherry picked from commit 1f5e7224868109a170a9248d18f8d2b6124e9c5a)
Diffstat (limited to 'include/cmake.mk')
-rw-r--r--include/cmake.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index de8022ca57..96c4d7df34 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -15,7 +15,7 @@ MAKE_PATH = $(firstword $(CMAKE_BINARY_SUBDIR) .)
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
cmake_tool=$(TOOLCHAIN_DIR)/bin/$(1)
else
- cmake_tool=$(shell command -v $(1))
+ cmake_tool=$(shell which $(1))
endif
ifeq ($(CONFIG_CCACHE),)