aboutsummaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-19 02:37:56 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-19 02:37:56 +0000
commitdb48122fb3e7cc1b9f98ec75b6626554bdf9b80b (patch)
tree542ffb108e03d844c600bf2efee97a8eb08495e9 /include/autotools.mk
parentb1ea33a4f848115eaceb195a9bc13b97ba8857be (diff)
downloadupstream-db48122fb3e7cc1b9f98ec75b6626554bdf9b80b.tar.gz
upstream-db48122fb3e7cc1b9f98ec75b6626554bdf9b80b.tar.bz2
upstream-db48122fb3e7cc1b9f98ec75b6626554bdf9b80b.zip
[include] autotools.mk: add a (dummy) libintl build dependency to any package using the libtool fixup
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24700 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 5e1c1053e4..592fcdebd7 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -61,14 +61,14 @@ define autoreconf_target
endef
ifneq ($(filter libtool,$(PKG_FIXUP)),)
- PKG_BUILD_DEPENDS += libtool
+ PKG_BUILD_DEPENDS += libtool libintl
ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
Hooks/Configure/Pre += autoreconf_target
endif
endif
ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
- PKG_BUILD_DEPENDS += libtool
+ PKG_BUILD_DEPENDS += libtool libintl
ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
Hooks/Configure/Pre += autoreconf_target
endif