aboutsummaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-08-19 17:46:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-08-19 17:46:11 +0000
commitb480498d1beaeab7fdf65307fe10b7dd5821bc45 (patch)
tree391a852d8f0f51ba16611b920ed9f2c68a4407e3 /include/autotools.mk
parent256fcc78774250bf92f028fa1a58337f649c33c3 (diff)
downloadupstream-b480498d1beaeab7fdf65307fe10b7dd5821bc45.tar.gz
upstream-b480498d1beaeab7fdf65307fe10b7dd5821bc45.tar.bz2
upstream-b480498d1beaeab7fdf65307fe10b7dd5821bc45.zip
fix libtool fixup for libstdc++
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22732 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index c941a4949d..1ddb49b7d4 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -38,7 +38,7 @@ autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
define libtool_fixup_libdir
find $(1) -name '*.la' | $(XARGS) \
$(SED) "s,\(^libdir='\| \|-L\|^dependency_libs='\)/usr/lib,\1$(STAGING_DIR)/usr/lib,g" \
- -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/usr/lib/\1.la,g"
+ -e "s,$(STAGING_DIR)/usr/lib/\(libstdc++\|libsupc++\).la,$(TOOLCHAIN_DIR)/lib/\1.la,g"
endef
define remove_version_check