diff options
author | Michael Pratt <mcpratt@pm.me> | 2023-05-25 02:31:17 -0400 |
---|---|---|
committer | Petr Štetiar <ynezz@true.cz> | 2023-06-12 22:10:20 +0200 |
commit | 948dc515dc5afca45a233471535e7c463866c9a9 (patch) | |
tree | a3ab265dc98c7cf7970ad3e5a49fc77324f600c7 /Makefile | |
parent | 145d485d51330c40deccce8e249a1da4b1c283ca (diff) | |
download | upstream-948dc515dc5afca45a233471535e7c463866c9a9.tar.gz upstream-948dc515dc5afca45a233471535e7c463866c9a9.tar.bz2 upstream-948dc515dc5afca45a233471535e7c463866c9a9.zip |
treewide: add ORIG_PATH variable
Add a variable that stores the original value of $PATH
in the host system's shell, before Make alters it.
This can be useful for when it is necessary
to ignore symlinks and programs made by the build system.
Define this new variable before all instances of
'export PATH:=' or similar.
Signed-off-by: Michael Pratt <mcpratt@pm.me>
(cherry picked from commit d87a8aa148ddf93b199a759deb088fff73787025)
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 2 |
1 files changed, 2 insertions, 0 deletions
@@ -15,6 +15,8 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir world: DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep '/usr' -m 1) + +export ORIG_PATH:=$(if $(ORIG_PATH),$(ORIG_PATH),$(PATH)) export PATH:=$(if $(STAGING_DIR),$(abspath $(STAGING_DIR)/../host/bin),$(TOPDIR)/staging_dir/host/bin):$(PATH) ifneq ($(OPENWRT_BUILD),1) |