diff options
author | Petr Štetiar <ynezz@true.cz> | 2019-09-20 14:54:56 +0200 |
---|---|---|
committer | Petr Štetiar <ynezz@true.cz> | 2019-10-09 21:07:13 +0200 |
commit | f2c321fc078e5e210aac97216f26c8c97cd7b93d (patch) | |
tree | 036018f5dbada7f8369b776de99119d9814d9836 /Makefile | |
parent | 5e9aae9ef069912edea21f807be5512249971127 (diff) | |
download | upstream-f2c321fc078e5e210aac97216f26c8c97cd7b93d.tar.gz upstream-f2c321fc078e5e210aac97216f26c8c97cd7b93d.tar.bz2 upstream-f2c321fc078e5e210aac97216f26c8c97cd7b93d.zip |
build: fix host menu config targets using ncurses
On a recent Gentoo Linux installation, invoking `make menuconfig`, `make
kernel_menuconfig` or `make kernel_nconfig` in the build system fails,
whereas for example `make menuconfig` in the kernel tree alone works as
expected.
This is happening because STAGING_PREFIX is not defined when kernel's
{menu,n}config target calls pkg-config from the toolchain/host and thus
pkg-config returns an empty value, and the fallback values in the kernel
config script are applied but those are off and the linking fails.
Solution is to use system's pkg-config for all ncurses based menu config
targets in order to provide proper compiler/linker flags.
Ref: FS#2423
Cc: Thomas Albers <thomas.gameiro@gmail.com>
Tested-by: Stijn Tintel <stijn@linux-ipv6.be>
Tested-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit 965f341aa9fdb6e07d509d02a6ca188af050292a)
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -18,6 +18,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir world: +DISTRO_PKG_CONFIG:=$(shell which -a pkg-config | grep -E '\/usr' | head -n 1) export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH) ifneq ($(OPENWRT_BUILD),1) |