aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2019-10-13 09:53:40 -1000
committerJo-Philipp Wich <jo@mein.io>2019-10-18 16:15:29 +0200
commit6fe6853d7e707d018fdaf1a8557d94217775d50c (patch)
tree3ac50fcbc49949e68ee00e395a71a0017a58e3f7 /Makefile
parent3468a4435a25268068b018e47c8da84d51440b5b (diff)
downloadupstream-6fe6853d7e707d018fdaf1a8557d94217775d50c.tar.gz
upstream-6fe6853d7e707d018fdaf1a8557d94217775d50c.tar.bz2
upstream-6fe6853d7e707d018fdaf1a8557d94217775d50c.zip
build: add buildinfo as single Makefile target
The prepare target was added some 11 years ago to build tools and toolchain and was recently extended to create buildinfo files for reproducibility, meaning {feeds,version,config}.buildinfo. As the buildbot workflow is more complex than the single prepare (kmod feed insertion), prepare is only used to create those buildinfo files. Running prepare however runs `target/compile` as well, taking time even everything is already compiled. Splitting this allows the buildbot to run only the `buildinfo` target while others can still use the convenience feature `prepare`. Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 6caf437652d858e5795ee16bdaf9f0436d2488f9)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 65ee10a84b..181c33b180 100644
--- a/Makefile
+++ b/Makefile
@@ -100,9 +100,12 @@ diffconfig: FORCE
mkdir -p $(BIN_DIR)
$(SCRIPT_DIR)/diffconfig.sh > $(BIN_DIR)/config.buildinfo
-prepare: .config $(tools/stamp-compile) $(toolchain/stamp-compile)
+buildinfo: FORCE
$(_SINGLE)$(SUBMAKE) -r diffconfig buildversion feedsversion
+prepare: .config $(tools/stamp-compile) $(toolchain/stamp-compile)
+ $(_SINGLE)$(SUBMAKE) -r buildinfo
+
world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
$(_SINGLE)$(SUBMAKE) -r package/index
$(_SINGLE)$(SUBMAKE) -r checksum