aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-03-21 16:15:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-03-21 16:15:01 +0000
commit4f6baffce7867867b4894c94938c7dc86964c736 (patch)
tree1d3d652cb05708ebbf1223fc02903f4c912a8090 /Makefile
parentf7d1e2178984e6081a150e3445a6c45c695c6edc (diff)
downloadupstream-4f6baffce7867867b4894c94938c7dc86964c736.tar.gz
upstream-4f6baffce7867867b4894c94938c7dc86964c736.tar.bz2
upstream-4f6baffce7867867b4894c94938c7dc86964c736.zip
check config changes on make world
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@410 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 8342bab86b..ef60ff1988 100644
--- a/Makefile
+++ b/Makefile
@@ -69,9 +69,13 @@ package_install: toolchain
# In this section, we need .config
include .config.cmd
-world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
+world: $(DL_DIR) $(BUILD_DIR) configtest target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
-.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
+.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install configtest
+
+configtest:
+ -cp .config .config.test
+ -scripts/configtest.pl
package_index:
(cd $(PACKAGE_DIR); \