aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-05 14:05:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-05 14:05:22 +0000
commit91d16e05832908f4a8145d431d772db672e3b1c3 (patch)
tree63fa3d283785c1c43fa07a80c0ee4d323ac47aee /Makefile
parent0ee5468453ce16b597d5a6afdea556e7a158bd53 (diff)
downloadupstream-91d16e05832908f4a8145d431d772db672e3b1c3.tar.gz
upstream-91d16e05832908f4a8145d431d772db672e3b1c3.tar.bz2
upstream-91d16e05832908f4a8145d431d772db672e3b1c3.zip
add target package/target_name to the master makefile, which will run $(MAKE) -C package target_name. same for target/ and toolchain/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1147 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e935295e6c..1b8d968a09 100644
--- a/Makefile
+++ b/Makefile
@@ -74,7 +74,6 @@ package_install: package_compile toolchain
#
#############################################################
-
# In this section, we need .config
include .config.cmd
@@ -108,6 +107,16 @@ $(BUILD_DIR):
source: $(TARGETS_SOURCE)
+
+package/%:
+ $(MAKE) -C package $(patsubst package/%,%,$@)
+
+target/%:
+ $(MAKE) -C target $(patsubst target/%,%,$@)
+
+toolchain/%:
+ $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+
#############################################################
#
# Cleanup and misc junk