aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2007-04-07 10:31:46 +0000
committerMike Baker <mbm@openwrt.org>2007-04-07 10:31:46 +0000
commite13a9d1a8dce56ba3ca3624767f26191fa226653 (patch)
treed55fe8511f8e2d78567236ca3e364efa42c31af5 /Makefile
parent87caff348210a2d7ab74bffb859201f098aa1a9f (diff)
downloadupstream-e13a9d1a8dce56ba3ca3624767f26191fa226653.tar.gz
upstream-e13a9d1a8dce56ba3ca3624767f26191fa226653.tar.bz2
upstream-e13a9d1a8dce56ba3ca3624767f26191fa226653.zip
fix menuconfig checks
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6879 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 43ed005b8a..fffc3bf5da 100644
--- a/Makefile
+++ b/Makefile
@@ -90,8 +90,9 @@ oldconfig: scripts/config/conf tmp/.config-target.in tmp/.config-package.in FORC
$< -o Config.in
menuconfig: scripts/config/mconf tmp/.config-target.in tmp/.config-package.in FORCE
- @[ -f .config ] || \
- [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config
+ @[ -f .config ] || { \
+ [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
+ }
$< Config.in
kernel_menuconfig: .config FORCE