aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-12 01:55:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-12 01:55:28 +0000
commit39968194002433a9e0313e4189585f31abeacaf7 (patch)
tree9c245e5990a829b3c87a13a609cec2142fd3439b /Makefile
parente97c3c74fb20530196e220a3670a21c3c7c0c049 (diff)
downloadupstream-39968194002433a9e0313e4189585f31abeacaf7.tar.gz
upstream-39968194002433a9e0313e4189585f31abeacaf7.tar.bz2
upstream-39968194002433a9e0313e4189585f31abeacaf7.zip
another optimization
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5507 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d6b1b7d618..62a0338746 100644
--- a/Makefile
+++ b/Makefile
@@ -21,10 +21,15 @@ SHELL:=/usr/bin/env bash
export LC_ALL=C
export LANG=C
export TOPDIR=${shell pwd}
-include $(TOPDIR)/include/verbose.mk
ifeq ($(KBUILD_VERBOSE),99)
MAKE:=3>/dev/null $(MAKE)
endif
+ifneq ($(shell tty -s <&3 || echo x),x)
+ IS_TTY=1
+ export IS_TTY
+endif
+
+include $(TOPDIR)/include/verbose.mk
OPENWRTVERSION:=$(RELEASE)
ifneq ($(VERSION),)