aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-02-19 13:00:30 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-02-19 13:00:30 +0000
commit1992d1fcbfe0c9af04618faff0593d41924c16d6 (patch)
treef4e652c161de4b02c34416cff43f59a96607c27a /Makefile
parent78c027e7cc93b2794950a4d5be087c0021b65824 (diff)
downloadupstream-1992d1fcbfe0c9af04618faff0593d41924c16d6.tar.gz
upstream-1992d1fcbfe0c9af04618faff0593d41924c16d6.tar.bz2
upstream-1992d1fcbfe0c9af04618faff0593d41924c16d6.zip
demistifying make *clean targets, fix some clean targets issues
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@272 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/Makefile b/Makefile
index 17507b9f8e..43ee3ddba5 100644
--- a/Makefile
+++ b/Makefile
@@ -27,8 +27,7 @@ CONFIG_DEFCONFIG = .defconfig
CONFIG = package/config
noconfig_targets := menuconfig config oldconfig randconfig \
- defconfig allyesconfig allnoconfig clean distclean \
- release tags
+ defconfig allyesconfig allnoconfig release tags
# Pull in the user's configuration file
ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
@@ -127,17 +126,17 @@ source: $(TARGETS_SOURCE)
# Cleanup and misc junk
#
#############################################################
-clean: $(TARGETS_CLEAN)
- rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE)
+clean:
+ rm -rf $(TARGET_DIR) $(IMAGE).*
+ $(MAKE) $(DIST)-image-clean
dirclean: $(TARGETS_DIRCLEAN)
- rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE)
-
-distclean:
- rm -rf $(DL_DIR) $(BUILD_DIR) $(LINUX_KERNEL) $(IMAGE)
+ rm -rf $(TARGET_DIR) $(IMAGE).*
+ $(MAKE) $(DIST)-image-clean
-cleanall:
- rm -rf $(DL_DIR) $(BUILD_DIR) $(LINUX_KERNEL) $(IMAGE) $(TOOL_BUILD_DIR)
+distclean: clean
+ rm -rf $(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR)
+ rm .config* .tmpconfig.h
sourceball:
rm -rf $(BUILD_DIR)
@@ -194,8 +193,8 @@ defconfig: $(CONFIG)/conf
# Cleanup and misc junk
#
#############################################################
-clean:
- - $(MAKE) -C $(CONFIG) clean
+clean:
+ @$(MAKE) -C $(CONFIG) clean
distclean: clean
@@ -204,4 +203,3 @@ endif # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
.PHONY: dummy subdirs release distclean clean config oldconfig \
menuconfig tags check test depend
-