aboutsummaryrefslogtreecommitdiffstats
path: root/Config.in
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-14 20:26:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-14 20:26:04 +0000
commit0ec23389f8d1ffe5e78d2b91f16a5b2d1202cabd (patch)
tree1d1c315a271b098592c1dd1756b91a5117d85c1c /Config.in
parent8ef94e67c30efa29aa74956a981a9aee4a75dac9 (diff)
downloadupstream-0ec23389f8d1ffe5e78d2b91f16a5b2d1202cabd.tar.gz
upstream-0ec23389f8d1ffe5e78d2b91f16a5b2d1202cabd.tar.bz2
upstream-0ec23389f8d1ffe5e78d2b91f16a5b2d1202cabd.zip
build: add a config option for choosing the prefered standard c++ library and add uclibc++.mk to make this easy to handle in packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32369 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Config.in')
-rw-r--r--Config.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/Config.in b/Config.in
index ddf02614b3..5f61905c92 100644
--- a/Config.in
+++ b/Config.in
@@ -395,6 +395,21 @@ menu "Global build settings"
Note that this will make the system libraries incompatible with most of the packages
that are not selected during the build process
+ choice
+ prompt "Preferred standard C++ library"
+ default USE_LIBSTDCXX if USE_EGLIBC
+ default USE_UCLIBCXX
+ help
+ Select the preferred standard C++ library for all packages that support this.
+
+ config USE_UCLIBCXX
+ bool "uClibc++"
+
+ config USE_LIBSTDCXX
+ bool "libstdc++"
+
+ endchoice
+
endmenu
menuconfig DEVEL