aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2023-04-18 03:34:23 +0000
committerPetr Štetiar <ynezz@true.cz>2023-06-13 14:14:25 +0200
commit4177b69b465e35c735ea57e9e57e233965c10568 (patch)
treebaec4d635e6ced5ebc8491e5010205ce35078007
parentbbd1676cd2bb02f537cc19366c2872c1f5b6cc96 (diff)
downloadupstream-4177b69b465e35c735ea57e9e57e233965c10568.tar.gz
upstream-4177b69b465e35c735ea57e9e57e233965c10568.tar.bz2
upstream-4177b69b465e35c735ea57e9e57e233965c10568.zip
armvirt: package and select Rockchip DWMAC Ethernet driver
For devices that implement the "rockchip,*-gmac" compatible controller, including: - RK3328 - RK3399 - RK3568 - RK3588 - PX30 Signed-off-by: Mathew McBride <matt@traverse.com.au> (cherry picked from commit abbffe55ddded36d2a4d0eee6e96c742eaffbbd2)
-rw-r--r--target/linux/armvirt/image/Makefile4
-rw-r--r--target/linux/armvirt/modules.mk11
2 files changed, 13 insertions, 2 deletions
diff --git a/target/linux/armvirt/image/Makefile b/target/linux/armvirt/image/Makefile
index a4c0c17ec6..e3031d5a13 100644
--- a/target/linux/armvirt/image/Makefile
+++ b/target/linux/armvirt/image/Makefile
@@ -109,8 +109,8 @@ define Device/generic
kmod-i2c-mux-pca954x kmod-gpio-pca953x partx-utils kmod-wdt-sp805 \
kmod-mvneta kmod-mvpp2 kmod-fsl-dpaa1-net kmod-fsl-dpaa2-net \
kmod-fsl-enetc-net kmod-dwmac-imx kmod-fsl-fec kmod-thunderx-net \
- kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom kmod-phy-marvell \
- kmod-phy-marvell-10g kmod-atlantic
+ kmod-dwmac-rockchip kmod-dwmac-sun8i kmod-phy-aquantia kmod-phy-broadcom \
+ kmod-phy-marvell kmod-phy-marvell-10g kmod-atlantic
endef
TARGET_DEVICES += generic
diff --git a/target/linux/armvirt/modules.mk b/target/linux/armvirt/modules.mk
index f94b25aad4..5826c545b7 100644
--- a/target/linux/armvirt/modules.mk
+++ b/target/linux/armvirt/modules.mk
@@ -244,6 +244,17 @@ endef
$(eval $(call KernelPackage,dwmac-sun8i))
+define KernelPackage/dwmac-rockchip
+ SUBMENU=$(NETWORK_DEVICES_MENU)
+ TITLE:=Rockchip RK3328/RK3399/RK3568 Ethernet
+ DEPENDS:=+kmod-stmmac-core +kmod-mdio-bus-mux
+ KCONFIG:=CONFIG_DWMAC_ROCKCHIP
+ FILES=$(LINUX_DIR)/drivers/net/ethernet/stmicro/stmmac/dwmac-rk.ko
+ AUTOLOAD=$(call AutoLoad,45,dwmac-rk)
+endef
+
+$(eval $(call KernelPackage,dwmac-rockchip))
+
define KernelPackage/thunderx-net
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Marvell (Cavium) ThunderX/2 network drivers