aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathew McBride <matt@traverse.com.au>2022-01-12 05:53:55 +0000
committerPetr Štetiar <ynezz@true.cz>2023-06-13 14:12:30 +0200
commit0bedcbb9ffd10158760dc3b57e6650ffaa562f26 (patch)
tree706d2000611b14e98043418a164507e9bb109490
parent04d2f8f11fc4c1809c297b5b90fddbad98ce905d (diff)
downloadupstream-0bedcbb9ffd10158760dc3b57e6650ffaa562f26.tar.gz
upstream-0bedcbb9ffd10158760dc3b57e6650ffaa562f26.tar.bz2
upstream-0bedcbb9ffd10158760dc3b57e6650ffaa562f26.zip
build: enable vmdk/vmware images for arm64 target
This is useful for VMware's ARM64 products, e.g Fusion for M1/ARM Macs. Signed-off-by: Mathew McBride <matt@traverse.com.au> (cherry picked from commit f899e0e024825861e129b0e8fbfb31c1d614273a)
-rw-r--r--config/Config-images.in2
-rw-r--r--target/linux/armvirt/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/config/Config-images.in b/config/Config-images.in
index 396f1dd3e3..d92c31ec5f 100644
--- a/config/Config-images.in
+++ b/config/Config-images.in
@@ -267,7 +267,7 @@ menu "Target Images"
config VMDK_IMAGES
bool "Build VMware image files (VMDK)"
- depends on TARGET_x86
+ depends on TARGET_x86 || TARGET_armvirt
depends on GRUB_IMAGES || GRUB_EFI_IMAGES
select PACKAGE_kmod-e1000
diff --git a/target/linux/armvirt/Makefile b/target/linux/armvirt/Makefile
index 34e032fe9e..04ff914b96 100644
--- a/target/linux/armvirt/Makefile
+++ b/target/linux/armvirt/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
BOARD:=armvirt
BOARDNAME:=QEMU ARM Virtual Machine
FEATURES:=fpu pci pcie rtc usb boot-part rootfs-part
-FEATURES+=cpiogz ext4 ramdisk squashfs targz
+FEATURES+=cpiogz ext4 ramdisk squashfs targz vmdk
KERNEL_PATCHVER:=5.15