aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKien Truong <duckientruong@gmail.com>2022-09-10 15:25:35 +0700
committerHauke Mehrtens <hauke@hauke-m.de>2022-09-11 01:30:11 +0200
commitfa468d4bcdc7e6eb84ea51d9b05368ed87c43aae (patch)
tree83d93b10cdf3d5e8f7a0efbd85865d0907d0b4b5
parent7b1740e2088e20bfa304407bf57a2bef5e9b39f1 (diff)
downloadupstream-fa468d4bcdc7e6eb84ea51d9b05368ed87c43aae.tar.gz
upstream-fa468d4bcdc7e6eb84ea51d9b05368ed87c43aae.tar.bz2
upstream-fa468d4bcdc7e6eb84ea51d9b05368ed87c43aae.zip
iproute2: add missing libbpf dependency
This patch adds libbpf to the dependencies of tc-mod-iptables. The package tc-mod-iptables is missing libbpf as a dependency, which leads to the build failure described in bug #9491 LIBBPF_FORCE=on set, but couldn't find a usable libbpf The build dependency is already automatically added because some other packages from iproute2 depend on libbpf, but bpftools has multiple build variants. With multiple build variants none gets build by default and the build system will not build bpftools before iproute2. Fixes: #9491 Signed-off-by: Kien Truong <duckientruong@gmail.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
-rw-r--r--package/network/utils/iproute2/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 4c21d4d877..5255400513 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -82,7 +82,7 @@ define Package/tc-mod-iptables
$(call Package/iproute2/Default)
TITLE:=Traffic control module - iptables action
VARIANT:=tcfull
- DEPENDS:=+libxtables
+ DEPENDS:=+libxtables +libbpf
endef
define Package/genl