aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2023-11-08 16:46:12 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2023-11-09 16:10:26 +0100
commitc9e8453de705818f45e306135b2ab6ce77ee8da3 (patch)
treef9bab0b49756d542c0f5ff782a419390341e2f44
parent2ef625e7696058208e129087d155ce65b10a3109 (diff)
downloadupstream-c9e8453de705818f45e306135b2ab6ce77ee8da3.tar.gz
upstream-c9e8453de705818f45e306135b2ab6ce77ee8da3.tar.bz2
upstream-c9e8453de705818f45e306135b2ab6ce77ee8da3.zip
hostapd: fix broke noscan option for mesh
noscan option for mesh was broken and actually never applied. This is caused by a typo where ssid->noscan value is check instead of conf->noscan resulting in the logic swapped and broken. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com> (cherry picked from commit 1b5ea2e199fcf391f88afd0322de449459399be4)
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/patches/301-mesh-noscan.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 73ec5e198d..f46c6275ef 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -5,7 +5,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/patches/301-mesh-noscan.patch b/package/network/services/hostapd/patches/301-mesh-noscan.patch
index 6b5416f0ea..0e654febd5 100644
--- a/package/network/services/hostapd/patches/301-mesh-noscan.patch
+++ b/package/network/services/hostapd/patches/301-mesh-noscan.patch
@@ -24,8 +24,8 @@
frequency);
goto out_free;
}
-+ if (ssid->noscan)
-+ conf->noscan = 1;
++ if (conf->noscan)
++ ssid->noscan = 1;
if (ssid->mesh_basic_rates == NULL) {
/*