aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2023-08-16 11:22:30 +0200
committerJo-Philipp Wich <jo@mein.io>2023-10-27 01:03:38 +0200
commit9eec4eb2684531ef146b9e4ff1a6c7545302fca9 (patch)
tree2a54c5d023b7b29fbf0dc626fba2dd4cc8d1d373
parent6150df13a369850f0d99ad418c2d580f4af940fb (diff)
downloadupstream-9eec4eb2684531ef146b9e4ff1a6c7545302fca9.tar.gz
upstream-9eec4eb2684531ef146b9e4ff1a6c7545302fca9.tar.bz2
upstream-9eec4eb2684531ef146b9e4ff1a6c7545302fca9.zip
prereq: make existing binary check work for sdk as well
To avoid replacing host built binaries with symlinks again, a check for an appropriate stamp was added in 729909c07f ("prereq-build: do not replace binaries with symlinks"). Unfortunately the stamp directory does not exist in the SDK, so the fix was ineffective there. This caused the packages builders to e.g. use the host tar again, which in turn made the tarballs created different since it may lack reproducibility fixes, or implement these differently, causing spurious hash failures on source repository based packages. Fix this by dropping the stamp dir check, and just check that the file is usable. Fixes: 729909c07f ("prereq-build: do not replace binaries with symlinks") Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com> (cherry picked from commit c1ef10c8d873254ce7c1f3019d821c4a87227474)
-rw-r--r--include/prereq.mk1
1 files changed, 0 insertions, 1 deletions
diff --git a/include/prereq.mk b/include/prereq.mk
index 88ed1f406a..5cb1102182 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -111,7 +111,6 @@ define SetupHostCommand
[ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
;; \
"-"*) \
- find "$(STAGING_DIR_HOST)/stamp" | grep $(strip $(1)) && \
[ -x "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0 \
;; \
*" -> /"*) \