aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArınç ÜNAL <arinc.unal@arinc9.com>2023-08-10 15:23:09 +0300
committerRafał Miłecki <rafal@milecki.pl>2023-10-26 08:50:44 +0200
commit97980323efd2df1d229f846ddb8677b7ea7091ff (patch)
treeae766948f571b270087fcaf525ec22341de82c48
parent07d4455cee161a0372a53ca8557ae1c35798e2e5 (diff)
downloadupstream-97980323efd2df1d229f846ddb8677b7ea7091ff.tar.gz
upstream-97980323efd2df1d229f846ddb8677b7ea7091ff.tar.bz2
upstream-97980323efd2df1d229f846ddb8677b7ea7091ff.zip
bcm53xx: add support for ASUS RT-AC3100
ASUS RT-AC3100 is ASUS RT-AC88U without the external switch. OpenWrt forum users effortless and ktmakwana have confirmed that there are revisions with either 4366b1 or 4366c0 wireless chips. Therefore, include firmware for 4366b1 along with 4366c0. This way, all hardware revisions of the router will be supported by having brcmfmac use the firmware file for the wireless chip it detects. Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com> (cherry picked from commit 2214bab3503981fe6168746acd13044a9d5e89e7)
-rw-r--r--target/linux/bcm53xx/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index b1eb4277b7..5158b432b3 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -159,6 +159,14 @@ define Device/asus
IMAGE/trx := append-ubi | trx-nand | asus-trx
endef
+define Device/asus_rt-ac3100
+ $(call Device/asus)
+ DEVICE_MODEL := RT-AC3100
+ DEVICE_PACKAGES := $(BRCMFMAC_4366B1) $(BRCMFMAC_4366C0) $(USB3_PACKAGES)
+ ASUS_PRODUCTID := RT-AC3100
+endef
+TARGET_DEVICES += asus_rt-ac3100
+
define Device/asus_rt-ac56u
$(call Device/asus)
DEVICE_MODEL := RT-AC56U