aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2023-02-07 21:33:33 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-02-19 19:44:39 +0100
commit7ae4716243dda59bcff21ba0ee704322b2db10f4 (patch)
tree395e9f674feb8f4fa404b7179139d8f7f358b9ab
parent4d384d28e44138c7619c0ab68b95cac21eeafbbf (diff)
downloadupstream-7ae4716243dda59bcff21ba0ee704322b2db10f4.tar.gz
upstream-7ae4716243dda59bcff21ba0ee704322b2db10f4.tar.bz2
upstream-7ae4716243dda59bcff21ba0ee704322b2db10f4.zip
toolchain: remove installing twice in the "initial" subdir
This was apparently introduced to recreate the toolchain (wipe staging_dir/toolchain*, but keep build_dir/toolchain*, followed by a `make toolchain/compile`). But it leaves leftovers and causes re-links to happen at src_install phase, because of the changed paths, possibly adding yet another source of issues. With the prior commits removing various hacks related to the "initial" folder we can remove installing it twice altogether. The recreated toolchain is exactly the same as before. Signed-off-by: Andre Heider <a.heider@gmail.com>
-rw-r--r--target/sdk/Makefile1
-rw-r--r--toolchain/binutils/Makefile7
-rw-r--r--toolchain/gcc/initial/Makefile4
3 files changed, 2 insertions, 10 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 89cc898e9d..d9f67dae9e 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -29,7 +29,6 @@ EXCLUDE_DIRS:= \
*/man \
*/info \
*/root-* \
- initial \
*.install.clean \
*.install.flags \
*.install \
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 636b8c4b11..42778d8d69 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -91,14 +91,9 @@ define Host/Compile
endef
define Host/Install
- mkdir -p $(TOOLCHAIN_DIR)/initial
$(MAKE) -C $(HOST_BUILD_DIR) \
- prefix=$(TOOLCHAIN_DIR)/initial \
install
- $(MAKE) -C $(HOST_BUILD_DIR) \
- prefix=$(TOOLCHAIN_DIR) \
- install
- $(call FixupLibdir,$(TOOLCHAIN_DIR)/initial)
+ $(call FixupLibdir,$(TOOLCHAIN_DIR))
$(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(HOST_BUILD_PREFIX)/bin/readelf
endef
diff --git a/toolchain/gcc/initial/Makefile b/toolchain/gcc/initial/Makefile
index 102fc070ae..7cb4a73dbc 100644
--- a/toolchain/gcc/initial/Makefile
+++ b/toolchain/gcc/initial/Makefile
@@ -19,12 +19,10 @@ endef
define Host/Install
+$(GCC_MAKE) $(HOST_JOBS) -C $(GCC_BUILD_DIR) \
- prefix="$(TOOLCHAIN_DIR)/initial" \
install-gcc \
install-target-libgcc
- $(call FixupLibdir,$(TOOLCHAIN_DIR)/initial)
- $$(call file_copy,$(TOOLCHAIN_DIR)/initial/.,$(TOOLCHAIN_DIR)/)
+ $(call FixupLibdir,$(TOOLCHAIN_DIR))
endef
$(eval $(call HostBuild))