aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Thomson <git@johnthomson.fastmail.com.au>2022-05-19 09:18:20 +1000
committerHauke Mehrtens <hauke@hauke-m.de>2022-09-11 01:30:11 +0200
commit62b72eafe49d2eecd3692691152ed86a0327fcb0 (patch)
treea02b117ffeb39c14d5b02e2c93ca883fe73d0a54
parent9423fc424c7313e470f61224eeebbaee3ff477a2 (diff)
downloadupstream-62b72eafe49d2eecd3692691152ed86a0327fcb0.tar.gz
upstream-62b72eafe49d2eecd3692691152ed86a0327fcb0.tar.bz2
upstream-62b72eafe49d2eecd3692691152ed86a0327fcb0.zip
ath79: mikrotik: use OpenWrt loader for initram image
Return to using the OpenWrt kernel loader to decompress and load kernel initram image. Continue to use the vmlinuz kernel for squashfs. Mikrotik's bootloader RouterBOOT on some ath79 devices is failing to boot the current initram, due to the size of the initram image. On the ath79 wAP-ac: a 5.7MiB initram image would fail to boot After this change: a 6.6MiB initram image successfully loads This partially reverts commit e91344776b9ba7c864be88d915c9c0df0eb790dd. An alternative of using RouterBOOT's capability of loading an initrd ELF section was investigated, but the OpenWrt kernel loader allows larger image. Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
-rw-r--r--target/linux/ath79/image/common-mikrotik.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/ath79/image/common-mikrotik.mk b/target/linux/ath79/image/common-mikrotik.mk
index 5f5fa7899a..fb3dc78226 100644
--- a/target/linux/ath79/image/common-mikrotik.mk
+++ b/target/linux/ath79/image/common-mikrotik.mk
@@ -1,8 +1,10 @@
define Device/mikrotik
DEVICE_VENDOR := MikroTik
+ LOADER_TYPE := elf
KERNEL_NAME := vmlinuz
KERNEL := kernel-bin | append-dtb-elf
- KERNEL_INITRAMFS := kernel-bin | append-dtb-elf
+ KERNEL_INITRAMFS_NAME := vmlinux-initramfs
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel
endef
define Device/mikrotik_nor