aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2023-10-26 16:11:47 +0000
committerPetr Štetiar <ynezz@true.cz>2023-11-02 14:44:46 +0000
commit4ef8899c7ab6ac9c69f7cc7138c3fc8a3fec777b (patch)
tree1b36e5d64067759357c8754a46c8acae7fa25b40
parentfdeb7d6dd050a56ede48e29f9ebfb5fe351328a5 (diff)
downloadupstream-4ef8899c7ab6ac9c69f7cc7138c3fc8a3fec777b.tar.gz
upstream-4ef8899c7ab6ac9c69f7cc7138c3fc8a3fec777b.tar.bz2
upstream-4ef8899c7ab6ac9c69f7cc7138c3fc8a3fec777b.zip
package-dumpinfo,metadata: add ABI version information to package index
There is no standard for ABI versioning, so its not possible to find out from `libext2fs2`, `libiwinfo20230701` or `libss2` package names if thats just package name or package name with ABI version included. To help with the decision, lets make ABI version aviable in package index. Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit 649655f427932fe79b96a41f883c8054b1806191)
-rw-r--r--include/package-dumpinfo.mk1
-rw-r--r--scripts/metadata.pm1
2 files changed, 2 insertions, 0 deletions
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index afc325c1ed..6baf10225d 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -37,6 +37,7 @@ $(if $(USERID),Require-User: $(USERID)
$(if $(LICENSE),License: $(LICENSE)
)$(if $(LICENSE_FILES),LicenseFiles: $(LICENSE_FILES)
)$(if $(PKG_CPE_ID),CPE-ID: $(PKG_CPE_ID)
+)$(if $(ABI_VERSION),ABI-Version: $(ABI_VERSION)
)Type: $(if $(Package/$(1)/targets),$(Package/$(1)/targets),$(if $(PKG_TARGETS),$(PKG_TARGETS),ipkg))
$(if $(KCONFIG),Kernel-Config: $(KCONFIG)
)$(if $(BUILDONLY),Build-Only: $(BUILDONLY)
diff --git a/scripts/metadata.pm b/scripts/metadata.pm
index e716f75d10..a00d19f185 100644
--- a/scripts/metadata.pm
+++ b/scripts/metadata.pm
@@ -257,6 +257,7 @@ sub parse_package_metadata($) {
/^License: \s*(.+)\s*$/ and $pkg->{license} = $1;
/^LicenseFiles: \s*(.+)\s*$/ and $pkg->{licensefiles} = $1;
/^CPE-ID: \s*(.+)\s*$/ and $pkg->{cpe_id} = $1;
+ /^ABI-Version: \s*(.+)\s*$/ and $pkg->{abi_version} = $1;
/^Default: \s*(.+)\s*$/ and $pkg->{default} = $1;
/^Provides: \s*(.+)\s*$/ and do {
my @vpkg = split /\s+/, $1;