aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-05-12 02:23:10 +0200
committerDaniel Golle <daniel@makrotopia.org>2023-05-12 02:27:17 +0200
commit43417aef846c76f30183c436055afc7d10b8b690 (patch)
treeec227158bf39493c40bc914f1d01069a4e86d182
parentf1f87ef3508c1e168b686d72e57166515999c313 (diff)
downloadupstream-43417aef846c76f30183c436055afc7d10b8b690.tar.gz
upstream-43417aef846c76f30183c436055afc7d10b8b690.tar.bz2
upstream-43417aef846c76f30183c436055afc7d10b8b690.zip
Revert "ath79: add empty squashfs-lzma filesystem"
This reverts commit 91e3419a33f3f0baa2fb25680f5c9a7b2240102b. Now that squashfs3-lzma generates reproducible output we can drop the empty binary. Having a binary file in the tree is not nice and we actually also use squashfs3-lzma for devices which expect the kernel to be loaded from a squashfs3... Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--include/image-commands.mk10
-rw-r--r--target/linux/ath79/image/Makefile3
-rwxr-xr-xtarget/linux/ath79/image/empty-squashfs-lzmabin150 -> 0 bytes
3 files changed, 10 insertions, 3 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index e1951672e6..0c13f30fef 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -103,6 +103,16 @@ define Build/append-rootfs
dd if=$(IMAGE_ROOTFS) >> $@
endef
+define Build/append-squashfs-fakeroot-be
+ rm -rf $@.fakefs $@.fakesquashfs
+ mkdir $@.fakefs
+ $(STAGING_DIR_HOST)/bin/mksquashfs3-lzma \
+ $@.fakefs $@.fakesquashfs \
+ -noappend -root-owned -be -nopad -b 65536 \
+ $(if $(SOURCE_DATE_EPOCH),-fixed-time $(SOURCE_DATE_EPOCH))
+ cat $@.fakesquashfs >> $@
+endef
+
define Build/append-squashfs4-fakeroot
rm -rf $@.fakefs $@.fakesquashfs
mkdir $@.fakefs
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 02fd26bfd8..8328be7667 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -60,9 +60,6 @@ define Build/relocate-kernel
rm -rf $@.relocate
endef
-define Build/append-squashfs-fakeroot-be
- cat ./empty-squashfs-lzma >> $@
-endef
define Device/Default
DEVICE_DTS_DIR := ../dts
diff --git a/target/linux/ath79/image/empty-squashfs-lzma b/target/linux/ath79/image/empty-squashfs-lzma
deleted file mode 100755
index 803a7661a7..0000000000
--- a/target/linux/ath79/image/empty-squashfs-lzma
+++ /dev/null
Binary files differ