aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandro Jäckel <sandro.jaeckel@gmail.com>2023-11-01 16:49:20 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-11-02 22:40:40 +0100
commit250ab7b7a5349626e16b49721ff08e82cf79a793 (patch)
tree65ba689435400d950d8af42b90dd7c6edb1ddb7a
parent592aacc3d9c08c5c61a0faa75729d6c27be80376 (diff)
downloadupstream-250ab7b7a5349626e16b49721ff08e82cf79a793.tar.gz
upstream-250ab7b7a5349626e16b49721ff08e82cf79a793.tar.bz2
upstream-250ab7b7a5349626e16b49721ff08e82cf79a793.zip
build: fix pkg-config detection when inside of a nix-shell
The output of command_all when inside a nix-shell looks like the below where /usr does not match: ➜ scripts/command_all.sh pkg-config /nix/store/ifr6srqgpvygd5vp14748d109ri31isv-pkg-config-wrapper-0.29.2/bin/pkg-config Signed-off-by: Sandro Jäckel <sandro.jaeckel@gmail.com> (cherry picked from commit 86ca7199dfb132042ce3110acef23d74f4ef14a7)
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index c325034bb9..9bdb03a443 100644
--- a/Makefile
+++ b/Makefile
@@ -14,7 +14,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
world:
-DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep '/usr' -m 1)
+DISTRO_PKG_CONFIG:=$(shell $(TOPDIR)/scripts/command_all.sh pkg-config | grep -e '/usr' -e '/nix/store' -m 1)
export ORIG_PATH:=$(if $(ORIG_PATH),$(ORIG_PATH),$(PATH))
export PATH:=$(if $(STAGING_DIR),$(abspath $(STAGING_DIR)/../host/bin),$(TOPDIR)/staging_dir/host/bin):$(PATH)