aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-06-16 23:26:50 +0200
committerDavid Bauer <mail@david-bauer.net>2023-03-10 02:31:50 +0100
commit14334c222e3a547db2e644a51c26e09b877d50a4 (patch)
tree036f6df12f9e597b6d49f93d4f99c563209761ed
parent73db6ca08b8f12fb210485fba5499beb7fe1aea3 (diff)
downloadupstream-14334c222e3a547db2e644a51c26e09b877d50a4.tar.gz
upstream-14334c222e3a547db2e644a51c26e09b877d50a4.tar.bz2
upstream-14334c222e3a547db2e644a51c26e09b877d50a4.zip
ath79: refactor devolo WiFi pro image definitions
Reuse common parts for the devolo WiFi pro series. The series is discontinued and we support all existing devices, so changes due to new revisions or models are highly unlikely Signed-off-by: David Bauer <mail@david-bauer.net>
-rw-r--r--target/linux/ath79/image/generic.mk29
1 files changed, 11 insertions, 18 deletions
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index be7481a384..7072dc131e 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -814,48 +814,41 @@ define Device/devolo_dlan-pro-1200plus-ac
endef
TARGET_DEVICES += devolo_dlan-pro-1200plus-ac
-define Device/devolo_dvl1200e
+define Device/devolo_wifi-pro
SOC := qca9558
DEVICE_VENDOR := devolo
- DEVICE_MODEL := WiFi pro 1200e
DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
IMAGE_SIZE := 15936k
endef
+
+define Device/devolo_dvl1200e
+ $(Device/devolo_wifi-pro)
+ DEVICE_MODEL := WiFi pro 1200e
+endef
TARGET_DEVICES += devolo_dvl1200e
define Device/devolo_dvl1200i
- SOC := qca9558
- DEVICE_VENDOR := devolo
+ $(Device/devolo_wifi-pro)
DEVICE_MODEL := WiFi pro 1200i
- DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
- IMAGE_SIZE := 15936k
endef
TARGET_DEVICES += devolo_dvl1200i
define Device/devolo_dvl1750c
- SOC := qca9558
- DEVICE_VENDOR := devolo
+ $(Device/devolo_wifi-pro)
DEVICE_MODEL := WiFi pro 1750c
- DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
- IMAGE_SIZE := 15936k
endef
TARGET_DEVICES += devolo_dvl1750c
define Device/devolo_dvl1750e
- SOC := qca9558
- DEVICE_VENDOR := devolo
+ $(Device/devolo_wifi-pro)
DEVICE_MODEL := WiFi pro 1750e
- DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
- IMAGE_SIZE := 15936k
+ DEVICE_PACKAGES += kmod-usb2
endef
TARGET_DEVICES += devolo_dvl1750e
define Device/devolo_dvl1750i
- SOC := qca9558
- DEVICE_VENDOR := devolo
+ $(Device/devolo_wifi-pro)
DEVICE_MODEL := WiFi pro 1750i
- DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
- IMAGE_SIZE := 15936k
endef
TARGET_DEVICES += devolo_dvl1750i