aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Thomson <git@johnthomson.fastmail.com.au>2022-03-28 11:50:44 +1000
committerFelix Fietkau <nbd@nbd.name>2022-03-28 11:03:13 +0200
commitf65596e8a9c34973ec2635cd37e77e7cf875424e (patch)
tree65e75d88c75974e20cdc90d82faf4b9235e648c5
parent3f8ea009d0321a3a4b5d891210e7942824a5714c (diff)
downloadupstream-f65596e8a9c34973ec2635cd37e77e7cf875424e.tar.gz
upstream-f65596e8a9c34973ec2635cd37e77e7cf875424e.tar.bz2
upstream-f65596e8a9c34973ec2635cd37e77e7cf875424e.zip
kernel: 5.15: fix mediatek usb module change
The mediatek USB kernel module xhci-mtk was restructed. The module after kernel 5.13 is named xhci-mtk-hcd. Link: https://lore.kernel.org/all/0b62e21ddfacc1c2874726dd27ccab80c993f303.1615170625.git.chunfeng.yun@mediatek.com/ Linux 14295a150050 ("usb: xhci-mtk: support to build xhci-mtk-hcd.ko") Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
-rw-r--r--package/kernel/linux/modules/usb.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index c12150fc5c..a52ba745ef 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1787,8 +1787,10 @@ define KernelPackage/usb-xhci-mtk
DEPENDS:=+kmod-usb-xhci-hcd
KCONFIG:=CONFIG_USB_XHCI_MTK
HIDDEN:=1
- FILES:=$(LINUX_DIR)/drivers/usb/host/xhci-mtk.ko
- AUTOLOAD:=$(call AutoLoad,54,xhci-mtk,1)
+ FILES:= \
+ $(LINUX_DIR)/drivers/usb/host/xhci-mtk.ko@lt5.13 \
+ $(LINUX_DIR)/drivers/usb/host/xhci-mtk-hcd.ko@ge5.13
+ AUTOLOAD:=$(call AutoLoad,54,xhci-mtk@lt5.13 xhci-mtk-hcd@gt5.13,1)
$(call AddDepends/usb)
endef