aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudiu Beznea <claudiu.beznea@microchip.com>2022-07-28 13:14:59 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2022-09-02 20:43:51 +0200
commite9f12931e60ee291cd7d2c8fd19a14682dae0197 (patch)
treee905ba8a1292c88826ec10f5518eceeb88853a79
parent9a49788008c18fd4fe6fefe9697962c102fb14c6 (diff)
downloadupstream-e9f12931e60ee291cd7d2c8fd19a14682dae0197.tar.gz
upstream-e9f12931e60ee291cd7d2c8fd19a14682dae0197.tar.bz2
upstream-e9f12931e60ee291cd7d2c8fd19a14682dae0197.zip
at91bootstrap: use sdmmc0 as booting media for sama5d27_som1_ek
Commit 0b7c66c ("at91bootstrap: add sama5d27_som1_eksd1_uboot as default defconfig") changed default booting media for sama5d27_som1_ek board w/o any reason. Changed it back to sdmmc0 as it is for all the other Microchip supported distributions for this board (Buildroot, Yocto Project). The initial commit cannot be cleanly reverted. Signed-off-by: Claudiu Beznea <claudiu.beznea@microchip.com>
-rw-r--r--package/boot/at91bootstrap/Makefile8
-rw-r--r--target/linux/at91/image/sama5.mk4
2 files changed, 3 insertions, 9 deletions
diff --git a/package/boot/at91bootstrap/Makefile b/package/boot/at91bootstrap/Makefile
index 1dd0f38fc2..efd42ecf5c 100644
--- a/package/boot/at91bootstrap/Makefile
+++ b/package/boot/at91bootstrap/Makefile
@@ -136,12 +136,6 @@ define AT91Bootstrap/sama5d27_som1_eksd_uboot
BUILD_DEVICES:=microchip_sama5d27-som1-ek
endef
-define AT91Bootstrap/sama5d27_som1_eksd1_uboot
- TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard1)
- BUILD_SUBTARGET:=sama5
- BUILD_DEVICES:=microchip_sama5d27-som1-ek
-endef
-
define AT91Bootstrap/sama5d27_som1_ekqspi_uboot
TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (QSPI Flash)
BUILD_SUBTARGET:=sama5
@@ -193,7 +187,7 @@ AT91BOOTSTRAP_TARGETS := \
sama5d4_xplainednf_uboot_secure \
sama5d4_xplaineddf_uboot_secure \
sama5d4_xplainedsd_uboot_secure \
- sama5d27_som1_eksd1_uboot \
+ sama5d27_som1_eksd_uboot \
sama5d27_som1_ekqspi_uboot \
sama5d27_wlsom1_eksd_uboot \
sama5d27_wlsom1_ekdf_qspi_uboot \
diff --git a/target/linux/at91/image/sama5.mk b/target/linux/at91/image/sama5.mk
index d108d27908..39db3e1cd0 100644
--- a/target/linux/at91/image/sama5.mk
+++ b/target/linux/at91/image/sama5.mk
@@ -19,8 +19,8 @@ define Build/at91-sdcard
$(BIN_DIR)/u-boot-$(DEVICE_DTS:at91-%=%)_mmc/u-boot.bin \
::u-boot.bin
- $(if $(findstring sama5d4-xplained,$@), \
- mcopy -i $@.boot \
+ $(if $(findstring sama5d4-xplained,$@), \
+ mcopy -i $@.boot \
$(BIN_DIR)/at91bootstrap-$(DEVICE_DTS:at91-%=%)sd_uboot_secure/at91bootstrap.bin \
::BOOT.bin,
mcopy -i $@.boot \