aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2023-06-06 13:05:50 +0100
committerDaniel Golle <daniel@makrotopia.org>2023-06-09 19:23:03 +0100
commite827f8f702da7b8095000d589978b494b15f02d1 (patch)
treea4050bfbaa2371d09b73cf2ab89f5a54e016aa03
parent703a5519cbf38855f9d496479c5d385032f97839 (diff)
downloadupstream-e827f8f702da7b8095000d589978b494b15f02d1.tar.gz
upstream-e827f8f702da7b8095000d589978b494b15f02d1.tar.bz2
upstream-e827f8f702da7b8095000d589978b494b15f02d1.zip
mediatek: use DEVICE_DTC_FLAGS and drop DTC_FLAGS where not needed
The MT7986 RFB was intended to use device tree overlays and for that reason modified DTC_FLAGS. zyxel_ex5601-t0-stock later on probably copied it from there. Both boards do not actually use device tree overlays, so remove setting DTC_FLAGS from both. The BPi-R3 does use device tree overlays, use DEVICE_DTC_FLAGS to give it an extra 4kb of padding for overlays to be applied. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit 98e6ea32a400b10b425e0efdf5a8109a0dfd48fe)
-rw-r--r--target/linux/mediatek/image/filogic.mk4
1 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/mediatek/image/filogic.mk b/target/linux/mediatek/image/filogic.mk
index 31c576983b..6323a05de2 100644
--- a/target/linux/mediatek/image/filogic.mk
+++ b/target/linux/mediatek/image/filogic.mk
@@ -135,7 +135,7 @@ define Device/bananapi_bpi-r3
KERNEL_INITRAMFS := kernel-bin | lzma | \
fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd | pad-to 64k
IMAGE/sysupgrade.itb := append-kernel | fit gzip $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb external-static-with-rootfs | pad-rootfs | append-metadata
- DTC_FLAGS += -@ --space 32768
+ DEVICE_DTC_FLAGS := --pad 4096
DEVICE_COMPAT_VERSION := 1.1
DEVICE_COMPAT_MESSAGE := Device tree overlay mechanism needs bootloader update
endef
@@ -195,7 +195,6 @@ define Device/mediatek_mt7986a-rfb-nand
fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
KERNEL_INITRAMFS = kernel-bin | lzma | \
fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd
- DTC_FLAGS += -@ --space 32768
endef
TARGET_DEVICES += mediatek_mt7986a-rfb-nand
@@ -367,6 +366,5 @@ define Device/zyxel_ex5601-t0-stock
fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb
KERNEL_INITRAMFS = kernel-bin | lzma | \
fit lzma $$(KDIR)/image-$$(firstword $$(DEVICE_DTS)).dtb with-initrd
- DTC_FLAGS += -@ --space 32768
endef
TARGET_DEVICES += zyxel_ex5601-t0-stock