aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2022-05-01 14:10:43 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-05-07 14:31:22 +0200
commitc97c8b814acc3b56fa15350ecefb0c246687e892 (patch)
tree20937f17d4c179060c7281cadf8c3161093df8e0
parent0cd1fc0fe543eaff04b0263b10b92b056cdef6dd (diff)
downloadupstream-c97c8b814acc3b56fa15350ecefb0c246687e892.tar.gz
upstream-c97c8b814acc3b56fa15350ecefb0c246687e892.tar.bz2
upstream-c97c8b814acc3b56fa15350ecefb0c246687e892.zip
kernel/x86: move x86' specific watchdogs to the x86 target
upstream linux have these watchdogs locked behind X86. These will not build on other architectures. So move them to target/linux/x86/modules.mk drivers/watchdog/Kconfig: |config F71808E_WDT | tristate "Fintek F718xx, F818xx Super I/O Watchdog" | depends on X86 |[...] |config IT87_WDT | tristate "IT87 Watchdog Timer" | depends on X86 |[...] |config ITCO_WDT | tristate "Intel TCO Timer/Watchdog" | depends on (X86 || IA64) && PCI |[...] |config W83627HF_WDT | tristate "Watchdog timer for W83627HF/W83627DHG and compatibles" | depends on X86 |[...] Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
-rw-r--r--package/kernel/linux/modules/other.mk65
-rw-r--r--target/linux/x86/modules.mk67
2 files changed, 67 insertions, 65 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 985652e945..802dd81bed 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1292,71 +1292,6 @@ endef
$(eval $(call KernelPackage,i6300esb-wdt))
-define KernelPackage/w83627hf-wdt
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Winbond 83627HF Watchdog Timer
- KCONFIG:=CONFIG_W83627HF_WDT
- FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/w83627hf_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,w83627hf-wdt,1)
-endef
-
-define KernelPackage/w83627hf-wdt/description
- Kernel module for Winbond 83627HF Watchdog Timer
-endef
-
-$(eval $(call KernelPackage,w83627hf-wdt))
-
-
-define KernelPackage/itco-wdt
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Intel iTCO Watchdog Timer
- KCONFIG:=CONFIG_ITCO_WDT \
- CONFIG_ITCO_VENDOR_SUPPORT=y
- FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/iTCO_wdt.ko \
- $(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/iTCO_vendor_support.ko
- AUTOLOAD:=$(call AutoLoad,50,iTCO_vendor_support iTCO_wdt,1)
-endef
-
-define KernelPackage/itco-wdt/description
- Kernel module for Intel iTCO Watchdog Timer
-endef
-
-$(eval $(call KernelPackage,itco-wdt))
-
-
-define KernelPackage/it87-wdt
- SUBMENU:=$(OTHER_MENU)
- TITLE:=ITE IT87 Watchdog Timer
- KCONFIG:=CONFIG_IT87_WDT
- FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/it87_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,it87-wdt,1)
- MODPARAMS.it87-wdt:= \
- nogameport=1 \
- nocir=1
-endef
-
-define KernelPackage/it87-wdt/description
- Kernel module for ITE IT87 Watchdog Timer
-endef
-
-$(eval $(call KernelPackage,it87-wdt))
-
-
-define KernelPackage/f71808e-wdt
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Fintek F718xx/F818xx Watchdog Timer
- DEPENDS:=@TARGET_x86
- KCONFIG:=CONFIG_F71808E_WDT
- FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/f71808e_wdt.ko
- AUTOLOAD:=$(call AutoProbe,f71808e-wdt,1)
-endef
-
-define KernelPackage/f71808e-wdt/description
- Kernel module for the watchdog timer found on many Fintek Super-IO chips.
-endef
-
-$(eval $(call KernelPackage,f71808e-wdt))
-
define KernelPackage/mhi-bus
SUBMENU:=$(OTHER_MENU)
TITLE:=MHI bus
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index 2f7f783c16..28cb276f7e 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -35,6 +35,22 @@ endef
$(eval $(call KernelPackage,amd-xgbe))
+define KernelPackage/f71808e-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Fintek F718xx/F818xx Watchdog Timer
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_F71808E_WDT
+ FILES:=$(LINUX_DIR)/drivers/watchdog/f71808e_wdt.ko
+ AUTOLOAD:=$(call AutoProbe,f71808e-wdt,1)
+endef
+
+define KernelPackage/f71808e-wdt/description
+ Kernel module for the watchdog timer found on many Fintek Super-IO chips.
+endef
+
+$(eval $(call KernelPackage,f71808e-wdt))
+
+
define KernelPackage/sound-cs5535audio
TITLE:=CS5535/CS5536 Audio Controller
DEPENDS:=@TARGET_x86_geode +kmod-ac97
@@ -84,6 +100,42 @@ endef
$(eval $(call KernelPackage,ib700-wdt))
+define KernelPackage/it87-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=ITE IT87 Watchdog Timer
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_IT87_WDT
+ FILES:=$(LINUX_DIR)/drivers/watchdog/it87_wdt.ko
+ AUTOLOAD:=$(call AutoLoad,50,it87-wdt,1)
+ MODPARAMS.it87-wdt:= \
+ nogameport=1 \
+ nocir=1
+endef
+
+define KernelPackage/it87-wdt/description
+ Kernel module for ITE IT87 Watchdog Timer
+endef
+
+$(eval $(call KernelPackage,it87-wdt))
+
+
+define KernelPackage/itco-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Intel iTCO Watchdog Timer
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_ITCO_WDT \
+ CONFIG_ITCO_VENDOR_SUPPORT=y
+ FILES:=$(LINUX_DIR)/drivers/watchdog/iTCO_wdt.ko \
+ $(LINUX_DIR)/drivers/watchdog/iTCO_vendor_support.ko
+ AUTOLOAD:=$(call AutoLoad,50,iTCO_vendor_support iTCO_wdt,1)
+endef
+
+define KernelPackage/itco-wdt/description
+ Kernel module for Intel iTCO Watchdog Timer
+endef
+
+$(eval $(call KernelPackage,itco-wdt))
+
define KernelPackage/pcengines-apuv2
SUBMENU:=$(OTHER_MENU)
@@ -121,3 +173,18 @@ define KernelPackage/meraki-mx100/description
endef
$(eval $(call KernelPackage,meraki-mx100))
+
+define KernelPackage/w83627hf-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Winbond 83627HF Watchdog Timer
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_W83627HF_WDT
+ FILES:=$(LINUX_DIR)/drivers/watchdog/w83627hf_wdt.ko
+ AUTOLOAD:=$(call AutoLoad,50,w83627hf-wdt,1)
+endef
+
+define KernelPackage/w83627hf-wdt/description
+ Kernel module for Winbond 83627HF Watchdog Timer
+endef
+
+$(eval $(call KernelPackage,w83627hf-wdt))