aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2022-10-18 08:55:46 +0200
committerPetr Štetiar <ynezz@true.cz>2022-10-18 19:05:06 +0200
commitb63d6d4730fd0dc30ce6707338c398e8b9d61d86 (patch)
tree33ec2f1adefeb79028c4532f5676949b0d0f761a
parent7129d1e9c9f7c6a4bde92c55c88009ecbc146da4 (diff)
downloadupstream-b63d6d4730fd0dc30ce6707338c398e8b9d61d86.tar.gz
upstream-b63d6d4730fd0dc30ce6707338c398e8b9d61d86.tar.bz2
upstream-b63d6d4730fd0dc30ce6707338c398e8b9d61d86.zip
mt7621: hiwifi_hc5962: fix reboot loop by using LZMA loader
This fixes a well known "LZMA ERROR 1" error, reported previously on numerous of similar devices. References: https://github.com/openwrt/openwrt/issues/10645#issuecomment-1282607274 Signed-off-by: Petr Štetiar <ynezz@true.cz>
-rw-r--r--target/linux/ramips/image/mt7621.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index f7bb0590d7..c1a9ecfaeb 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -880,6 +880,7 @@ TARGET_DEVICES += hilink_hlk-7621a-evb
define Device/hiwifi_hc5962
$(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_SIZE := 4096k